Skip to main content
VulnerabilityPublished

CVE-2026-35491: pi-hole FTL · Incorrect Authorization

Affects pi-hole FTLSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 6.6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade FTL and pi-hole/FTL to 6.6.

Affected software

ProductAffectedFixed in
pi-holeFTLAffected
  • >=6.0 <6.6
Fixed in
  • 6.6
GitHubpi-hole/FTLpkg:github/pi-hole/FTLOther threatsAffected
  • <6.6 >=6.0
Fixed in
  • 6.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Pi-hole FTL to version 6.6 or later where this vulnerability is fixed. Since the vulnerability is resolved in 6.6, applying this official fix fully mitigates the issue. No additional mitigations are indicated.

Description

A vulnerability in Pi-hole FTL versions 6.0 up to before 6.6 allows CLI-scoped API sessions, which are intended to be read-only, to bypass authorization and overwrite configuration via the /api/teleporter endpoint. This occurs because /api/teleporter did not properly restrict Teleporter imports for CLI sessions, unlike /api/config which correctly blocked such mutations. The issue is identified as CWE-863 (Incorrect Authorization) and has a CVSS score of 6.1 (medium severity). The vulnerability is fixed in version 6.6.

References

Community reviews

Loading reviews…