Skip to main content
VulnerabilityPublished

CVE-2026-35539: Roundcube Webmail · XSS or 'Cross-site Scripting'

Affects Roundcube WebmailSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.6.14 or 1.5.14 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.14, 1.5.14
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Webmail and roundcube/roundcubemail to 1.6.14 or 1.5.14.

Affected software

ProductAffectedFixed in
RoundcubeWebmailAffected
  • >=1.6.0 <1.6.14
Fixed in
  • 1.6.14
RoundcubeWebmailAffected
  • <1.5.14
Fixed in
  • 1.5.14
GitHubroundcube/roundcubemailpkg:github/roundcube/roundcubemailOther threatsAffected
  • <1.5.14
  • <1.6.14
Fixed in
  • 1.5.14
  • 1.6.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution when previewing HTML attachments and consider disabling attachment preview functionality if feasible.

Description

CVE-2026-35539 is a medium severity cross-site scripting (XSS) vulnerability in Roundcube Webmail versions before 1.5.14 and 1.6.14. The issue arises from insufficient sanitization of HTML attachments in preview mode, allowing an attacker to execute script code if a victim previews a crafted text/html attachment. This vulnerability requires user interaction to exploit and impacts confidentiality and integrity but not availability.

References

Community reviews

Loading reviews…