Skip to main content
VulnerabilityPublished

CVE-2026-35554: Apache Kafka Clients · Use After Free

Affects Apache Kafka ClientsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Kafka ClientsAffected
  • >=2.8.0 <=3.9.1
  • >=4.0.0 <=4.0.1
  • >=4.1.0 <=4.1.1
Fixed in–
MavenApache Software Foundation/org.apache.kafka:kafka-clientspkg:maven/Apache Software Foundation/org.apache.kafka:kafka-clientsOther threatsAffected
  • >=2.8.0 <=3.9.1
  • >=4.0.0 <=4.0.1
  • >=4.1.0 <=4.1.1
Fixed in–
Mavenorg.apache.kafka/kafka-clientspkg:maven/org.apache.kafka/kafka-clientsOther threatsAffected
  • =2.8.0
  • =4.0.0
  • =4.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Kafka clients to versions 3.9.2, 4.0.2, 4.1.2, 4.2.0, or later to remediate this vulnerability. No other mitigation or temporary workaround is documented. Patch status is confirmed by the vendor advisory recommending these fixed versions.

Description

CVE-2026-35554 is a high-severity use-after-free vulnerability in Apache Kafka Java producer clients up to versions 3.9.1, 4.0.1, and 4.1.1. It arises from a race condition in buffer pool management where expired produce batches can have their buffers prematurely deallocated and reused, causing message corruption. This can lead to messages being silently delivered to incorrect topics without error notification. The vulnerability impacts data confidentiality by potentially exposing messages to unintended consumers and data integrity by causing deserialization failures and corrupted downstream data.

References

Community reviews

Loading reviews…