Skip to main content
VulnerabilityPublished

CVE-2026-35565: Apache Storm UI · Cross-site Scripting

Affects Apache Storm UISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 2.8.6 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache Storm UI and Apache Software Foundation/org.apache.storm:storm-webapp and org.apache.storm/storm-ui to 2.8.6.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Storm UIAffected
  • <2.8.6
Fixed in
  • 2.8.6
MavenApache Software Foundation/org.apache.storm:storm-webapppkg:maven/Apache Software Foundation/org.apache.storm:storm-webappOther threatsAffected
  • <2.8.6
Fixed in
  • 2.8.6
Mavenorg.apache.storm/storm-uipkg:maven/org.apache.storm/storm-uiOther threatsAffected
  • <2.8.6
Fixed in
  • 2.8.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version, Apache Storm 2.8.6, is available and should be applied to remediate this vulnerability. For users unable to upgrade immediately, a monkey patch is recommended to HTML-escape all API-supplied values before insertion into the UI's tooltip HTML strings. Additionally, restricting topology submission to trusted users via Nimbus ACLs is advised as a defense-in-depth measure. Detailed patching guidance is provided in the 2.8.6 release notes.

Description

Stored Cross-Site Scripting (XSS) via Unsanitized Topology Metadata in Apache Storm UI Versions Affected: before 2.8.6 Description: The Storm UI visualization component interpolates topology metadata including component IDs, stream names, and grouping values directly into HTML via innerHTML in parseNode() and parseEdge() without sanitization at any layer. An authenticated user with topology submission rights could craft a topology containing malicious HTML/JavaScript in component identifiers (e.g., a bolt ID containing an onerror event handler). This payload flows through Nimbus → Thrift → the Visualization API → vis.js tooltip rendering, resulting in stored cross-site scripting. In multi-tenant deployments where topology submission is available to less-trusted users but the UI is accessed by operators or administrators, this enables privilege escalation through script execution in an admin's browser session. Mitigation: 2.x users should upgrade to 2.8.6. Users who cannot upgrade immediately should monkey-patch the parseNode() and parseEdge() functions in the visualization JavaScript file to HTML-escape all API-supplied values including nodeId, :capacity, :latency, :component, :stream, and :grouping before interpolation into tooltip HTML strings, and should additionally restrict topology submission to trusted users via Nimbus ACLs as a defense-in-depth measure. A guide on how to do this is available in the release notes of 2.8.6. Credit: This issue was discovered while investigating another report by K.

References

Community reviews

Loading reviews…