Skip to main content
VulnerabilityPublished

CVE-2026-35571: NationalSecurityAgency emissary · Cross-site Scripting

Affects NationalSecurityAgency emissarySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 8.39.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.39.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade emissary and nationalsecurityagency/emissary to 8.39.0.

Affected software

ProductAffectedFixed in
NationalSecurityAgencyemissaryAffected
  • <8.39.0
Fixed in
  • 8.39.0
GitHubnationalsecurityagency/emissarypkg:github/nationalsecurityagency/emissaryOther threatsAffected
  • <8.39.0
Fixed in
  • 8.39.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Emissary to version 8.39.0 or later, where this vulnerability is fixed. Since the fix is included in this version, applying this official update is the recommended remediation. Patch status is not explicitly confirmed beyond the fix in 8.39.0, so verify with the vendor advisory before deployment. No alternative mitigations or temporary fixes are indicated.

Description

CVE-2026-35571 is a stored cross-site scripting (XSS) vulnerability in the NationalSecurityAgency's Emissary product prior to version 8.39.0. The issue arises because Mustache navigation templates interpolate configuration-controlled link values directly into href attributes without validating the URL scheme. An administrator with the ability to modify the navItems configuration can inject javascript: URIs, leading to XSS attacks against other authenticated users of the Emissary web interface. This vulnerability has a medium severity with a CVSS score of 4.8. The vulnerability is fixed in Emissary version 8.39.0.

References

Community reviews

Loading reviews…