CVE-2026-9255: AWS Kiro CLI · Missing Authorization
Affects AWS Kiro CLISource CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 1.28.0 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.28.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade AWS Kiro CLI to 1.28.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AWSKiro CLI | Affected
| Fixed in
|
AI-suggested
AWS has released an official fix in Kiro CLI version 1.28.0. Users should upgrade to version 1.28.0 or later to remediate this vulnerability. Since this is a local attack vector, ensuring the upgrade is applied promptly will prevent exploitation. No additional mitigations are specified by the vendor advisory.
Description
CVE-2026-9255 is a high-severity vulnerability in AWS Kiro CLI versions before 1.28.0. It involves missing authorization validation in the tool authorization prompt, allowing a local attacker to execute arbitrary tools or shell commands without user approval by supplying crafted input via stdin. AWS has released version 1.28.0 to address this issue.