Skip to main content
VulnerabilityPublished

CVE-2026-35580: NationalSecurityAgency emissary · Command Injection

Affects NationalSecurityAgency emissarySource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 8.39.0 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.39.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade emissary and nationalsecurityagency/emissary to 8.39.0.

Affected software

ProductAffectedFixed in
NationalSecurityAgencyemissaryAffected
  • <8.39.0
Fixed in
  • 8.39.0
GitHubnationalsecurityagency/emissarypkg:github/nationalsecurityagency/emissaryOther threatsAffected
  • <8.39.0
Fixed in
  • 8.39.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Emissary version 8.39.0. Users should upgrade to version 8.39.0 or later to remediate this issue. No additional mitigations are specified.

Description

Emissary is a P2P based data-driven workflow engine. Prior to 8.39.0, GitHub Actions workflow files contained shell injection points where user-controlled workflow_dispatch inputs were interpolated directly into shell commands via ${{ }} expression syntax. An attacker with repository write access could inject arbitrary shell commands, leading to repository poisoning and supply chain compromise affecting all downstream users. This vulnerability is fixed in 8.39.0.

References

Community reviews

Loading reviews…