Skip to main content
VulnerabilityPublished Updated

CVE-2026-3610: HSC Cybersecurity Mailinspector · Cross-site Scripting

Affects HSC Cybersecurity MailinspectorSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.3 Medium.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
HSC CybersecurityMailinspectorAffected
  • =5.3.2-3
Fixed in–

AI-suggested

To mitigate CVE-2026-3610, organizations should immediately upgrade HSC Cybersecurity Mailinspector to version 5.4.0 or later, where the vulnerability is fully resolved. If immediate upgrade is not feasible, apply the vendor-provided hotfix to affected versions to block exploitation. Additionally, implement strict input validation and output encoding on the error_description parameter and other user-controllable inputs to prevent script injection. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in the browser context. Monitor web server logs and application behavior for unusual or suspicious requests targeting the vulnerable endpoint. Educate users about the risks of interacting with unexpected or suspicious error messages that could trigger XSS payloads. Finally, maintain an up-to-date inventory of Mailinspector deployments and ensure timely application of security patches as part of a robust vulnerability management program.

Description

A vulnerability was found in HSC Cybersecurity Mailinspector up to 5.3.2-3. Affected by this issue is some unknown functionality of the file /mailinspector/mliUserValidation.php of the component URL Handler. The manipulation of the argument error_description results in cross site scripting. The attack may be performed from remote. The exploit has been made public and could be used. Upgrading to version 5.4.0 can resolve this issue. You should upgrade the affected component. The vendor was contacted early and responded very professional: "We have already implemented the fix and made a hotfix available to affected customers, ensuring mitigation while the official release 5.4.0 has not yet been published. This allows customers to address the issue immediately, outside the regular release cycle."

References

Community reviews

Loading reviews…