Skip to main content
VulnerabilityPublished Updated

CVE-2026-38329: bludit · Missing Authorization

Affects bluditSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.18.4 as a priority.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.18.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade bludit/bludit to 3.18.4.

Affected software

ProductAffectedFixed in
Packagistbludit/bluditpkg:composer/bludit/bluditOther threatsAffected
  • <3.18.4
Fixed in
  • 3.18.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict API token issuance and usage to trusted users only. Monitor for suspicious API activity and consider disabling the vulnerable API Plugin if feasible.

Description

Bludit CMS versions prior to 3.18.4 contain a critical remote code execution vulnerability in the API Plugin. The vulnerability exists because the POST /api/files/{key} endpoint does not perform proper authorization checks and lacks file extension validation. An attacker with a valid API token can upload a malicious PHP script and execute arbitrary code on the server, leading to full compromise.

References

Community reviews

Loading reviews…