Skip to main content
VulnerabilityPublished

CVE-2026-112192: MISP · Information Exposure

Affects MISPSource CVE Database V5

0

Not known to be exploited · CVSS 5.3 Medium : upgrade to 2.5.48 when convenient.

Data as of 26 Oct 2026, 17:30 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CISA SSVC
Exploitation
No evidence of active exploitation and no public proof of concept
Automatable
Attackers cannot reliably automate steps 1–4 of the kill chain
Technical impact
Limited control over the software or limited information exposure

CISA SSVC assessment, 2026-10-19.

Patch
Available – fixed in 2.5.48
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade MISP to 2.5.48.

Affected software

ProductAffectedFixed in
MISPMISPAffected
  • <2.5.48
Fixed in
  • 2.5.48
GitHubMISPpkg:github/MISPOther threatsAffected
  • <2.5.48
Fixed in
  • 2.5.48

CPE configurations (1)

  • cpe:2.3:a:misp:misp:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade MISP to version 2.5.48 or later, where this vulnerability is fixed. The fix restores proper handling of the redacted and cli_only flags in module settings, preventing sensitive information exposure and unauthorized modification via the web API.

Description

MISP versions prior to 2.5.48 contain a vulnerability in the handling of module plugin settings where redacted and cli_only flags are dropped during server processing. This causes sensitive settings marked as redacted, such as API keys, to be exposed in full to any authenticated user with access to server settings. Additionally, settings intended to be modifiable only via CLI can be changed through the web API, bypassing intended restrictions.

References

Community reviews

Loading reviews…