CVE-2026-39243: decompress · Link Following
Affects decompressSource CVE Database V5
Not known to be exploited · CVSS 5.5 Medium : upgrade to 4.2.2 when convenient.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade decompress to 4.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmdecompresspkg:npm/decompressOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for decompress that fixes this vulnerability in version 4.2.2. Users should upgrade to version 4.2.2 or later to remediate this issue. Until patched, avoid extracting untrusted archives with decompress or implement additional validation on archive contents to prevent hardlink exploitation.
Description
A vulnerability in decompress versions before 4.2.2 allows an attacker to create arbitrary hardlinks during archive extraction. This occurs because the x.linkname field from the archive is used without validation when processing hardlink entries, enabling an attacker to link to any file on the same filesystem. This can lead to unauthorized reading and overwriting of files, causing file disclosure and corruption. The vulnerability is limited to files on the same filesystem and does not affect directories. A patch is available to address this issue.