Skip to main content
VulnerabilityPublished Updated

CVE-2026-39304: Apache ActiveMQ Client · Denial of Service via Out of Memory

Affects Apache ActiveMQ ClientSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 6.2.4 or 5.19.4 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.4, 5.19.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade Apache ActiveMQ Client and Apache ActiveMQ Broker and Apache ActiveMQ All and Apache ActiveMQ and org.apache.activemq/activemq and Apache Software Foundation/org.apache.activemq:activemq-client and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:apache-activemq and org.apache.activemq/activemq-client and org.apache.activemq/activemq-broker to 6.2.4 or 5.19.4.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQ ClientAffected
  • >=6.0.0 <6.2.4
Fixed in
  • 6.2.4
Apache Software FoundationApache ActiveMQ ClientAffected
  • <5.19.4
Fixed in
  • 5.19.4
Apache Software FoundationApache ActiveMQ BrokerAffected
  • >=6.0.0 <6.2.4
Fixed in
  • 6.2.4
Apache Software FoundationApache ActiveMQ BrokerAffected
  • <5.19.4
Fixed in
  • 5.19.4
Apache Software FoundationApache ActiveMQ AllAffected
  • >=6.0.0 <6.2.4
Fixed in
  • 6.2.4
Apache Software FoundationApache ActiveMQ AllAffected
  • <5.19.4
Fixed in
  • 5.19.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade affected Apache ActiveMQ Client, Broker, and Apache ActiveMQ versions to 5.19.5 or 6.2.4 or later to resolve this vulnerability. Patch status is confirmed by vendor advisories. No additional mitigations are specified.

Description

Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ. ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS. Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4. Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.

References

Community reviews

Loading reviews…