CVE-2026-39305: MervinPraison PraisonAI · Path Traversal
Affects MervinPraison PraisonAISource CVE Database V5
Not known to be exploited · CVSS 9.0 Critical : upgrade to 4.5.113 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.5.113, 1.5.113
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade PraisonAI to 4.5.113; mervinpraison/PraisonAI to 1.5.113.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MervinPraisonPraisonAI | Affected
| Fixed in
|
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix for this vulnerability is available in PraisonAI version 1.5.113. Users should upgrade to version 1.5.113 or later to remediate the issue. Since this is not a cloud service, remediation requires applying the vendor patch. There is no vendor advisory indicating that no action is required or that the issue is otherwise mitigated.
Description
PraisonAI is a multi-agent teams system. Prior to 1.5.113, the Action Orchestrator feature contains a Path Traversal vulnerability that allows an attacker (or compromised agent) to write to arbitrary files outside of the configured workspace directory. By supplying relative path segments (../) in the target path, malicious actions can overwrite sensitive system files or drop executable payloads on the host. This vulnerability is fixed in 1.5.113.