Skip to main content
VulnerabilityPublished

CVE-2026-39378: jupyter nbconvert · Path Traversal

Affects jupyter nbconvertSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 7.17.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.17.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade jupyter nbconvert to 7.17.1.

Affected software

ProductAffectedFixed in
jupyternbconvertAffected
  • >=6.5 <7.17.1
Fixed in
  • 7.17.1
PyPInbconvertpkg:pypi/nbconvertOther threatsAffected
  • >=6.5 <7.17.1
Fixed in
  • 7.17.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to jupyter nbconvert version 7.17.1 or later where the vulnerability is fixed. If upgrading is not immediately possible, do not enable the HTMLExporter.embed_images option, as it is disabled by default and enabling it triggers the vulnerability. No other specific mitigations are indicated.

Description

A path traversal vulnerability exists in jupyter nbconvert versions 6.5 through 7.17.0 when the HTMLExporter.embed_images option is enabled. This flaw allows a malicious notebook to read arbitrary files from the host system by embedding them as base64 data URIs in the output HTML. The vulnerability is fixed in version 7.17.1. By default, HTMLExporter.

References

Community reviews

Loading reviews…