Skip to main content
VulnerabilityPublished Updated

CVE-2026-39386: m1k1o neko · Improper Input Validation

Affects m1k1o nekoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 3.1.2 or 3.0.11 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.2, 3.0.11
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade neko and m1k1o/neko to 3.1.2 or 3.0.11.

Affected software

ProductAffectedFixed in
m1k1onekoAffected
  • >=3.1.0 <3.1.2
Fixed in
  • 3.1.2
m1k1onekoAffected
  • >=3.0.0 <3.0.11
Fixed in
  • 3.0.11
GitHubm1k1o/nekopkg:github/m1k1o/nekoOther threatsAffected
  • <3.0.11
  • >=3.0.0 <3.0.11
  • <3.1.2 >=3.1.0
Fixed in
  • 3.0.11
  • 3.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in versions 3.0.11 and 3.1.2 of m1k1o neko and upgrading to these versions is strongly recommended. If immediate upgrade is not possible, temporary mitigations include restricting access to trusted users only, enforcing strong passwords, running the instance only when needed, placing the instance behind additional authentication layers such as a reverse proxy, disabling or restricting access to the /api/profile endpoint if feasible, and monitoring for suspicious administrative actions. These mitigations reduce risk but do not fully resolve the vulnerability.

Description

Neko is a a self-hosted virtual browser that runs in Docker and uses WebRTC In versions 3.0.0 through 3.0.10 and 3.1.0 through 3.1.1, any authenticated user can immediately obtain full administrative control of the entire Neko instance (member management, room settings, broadcast control, session termination, etc.). This results in a complete compromise of the instance. The vulnerability has been patched in v3.0.11 and v3.1.2. If upgrading is not immediately possible, the following mitigations can reduce risk: Restrict access to trusted users only (avoid granting accounts to untrusted parties); ensure all user passwords are strong and only shared with trusted individuals; run the instance only when needed; avoid leaving it continuously exposed; place the instance behind authentication layers such as a reverse proxy with additional access controls; disable or restrict access to the /api/profile endpoint if feasible; and/or monitor for suspicious privilege changes or unexpected administrative actions. Note that these are temporary mitigations and do not fully eliminate the vulnerability. Upgrading is strongly recommended.

References

Community reviews

Loading reviews…