Skip to main content
VulnerabilityPublished Updated

CVE-2026-39389: ci4-cms-erp ci4ms · Improper Authorization

Affects ci4-cms-erp ci4msSource CVE Database V5

0

Not known to be exploited · CVSS 6.7 Medium : upgrade to 0.31.4.0 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.4.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.4.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.31.4.0
Fixed in
  • 0.31.4.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.31.4.0
Fixed in
  • 0.31.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ci4ms to version 0.31.4.0 or later, where this vulnerability is fixed. Since the vendor advisory does not specify alternative mitigations, applying the official fix is the recommended remediation. No additional temporary mitigations are provided.

Description

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to 0.31.4.0, This vulnerability is fixed in 0.31.4.0.

References

Community reviews

Loading reviews…