Skip to main content
VulnerabilityPublished

CVE-2026-39410: honojs hono · Improper Input Validation

Affects honojs honoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 4.12.12 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.12.12
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade hono and honojs/hono to 4.12.12.

Affected software

ProductAffectedFixed in
honojshonoAffected
  • <4.12.12
Fixed in
  • 4.12.12
GitHubhonojs/honopkg:github/honojs/honoOther threatsAffected
  • <4.12.12
Fixed in
  • 4.12.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade honojs hono to version 4.12.12 or later where this vulnerability is fixed. No other official remediation or temporary fixes are indicated. Patch status is not explicitly stated beyond the fix in version 4.12.12, so users should verify the upgrade to this version to mitigate the issue.

Description

A vulnerability in the honojs hono web application framework prior to version 4.12.12 allows bypass of cookie prefix protections due to inconsistent handling between browser cookie parsing and the parse() function. This discrepancy enables attacker-controlled cookies to override legitimate cookies by exploiting normalization differences. The issue is fixed in version 4.12.12. The vulnerability has a medium severity with a CVSS score of 4.8.

References

Community reviews

Loading reviews…