CVE-2026-39413: HKUDS LightRAG · Improper Verification of Cryptographic Signature
Affects HKUDS LightRAGSource CVE Database V5
Not known to be exploited · CVSS 4.2 Medium : upgrade to 1.4.14 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.14
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade LightRAG and lightrag to 1.4.14.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HKUDSLightRAG | Affected
| Fixed in
|
PyPIlightragpkg:pypi/lightragOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade LightRAG to version 1.4.14 or later, where the vulnerability is fixed by explicitly rejecting tokens with the 'none' algorithm. Until upgraded, avoid accepting JWT tokens that do not have a valid signature algorithm.
Description
LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.4.14, the LightRAG API is vulnerable to a JWT algorithm confusion attack where an attacker can forge tokens by specifying 'alg': 'none' in the JWT header. Since the jwt.decode() call does not explicitly deny the 'none' algorithm, a crafted token without a signature will be accepted as valid, leading to unauthorized access. This vulnerability is fixed in 1.4.14.