CVE-2026-39416: ail-framework · Cross-site Scripting
Affects ail-frameworkSource CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 6.8 soon.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 8 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ail-framework and ail-project/ail-framework to 6.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ail-projectail-framework | Affected
| Fixed in
|
GitHubail-project/ail-frameworkpkg:github/ail-project/ail-frameworkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ail-framework to version 6.8 or later, where this vulnerability is fixed. Patch status is confirmed fixed in version 6.8. No additional mitigations are specified.
Description
A stored cross-site scripting (XSS) vulnerability exists in ail-framework versions prior to 6.8. The issue occurs in the modal item preview functionality when processing item content longer than 800 characters. Attacker-controlled content is returned without an explicit text/plain content type, allowing browsers to interpret it as active HTML and execute arbitrary JavaScript in the context of an authenticated user. This vulnerability has a high severity score of 8.5 and is fixed in version 6.8.