CVE-2026-39419: 1Panel-dev MaxKB · Injection
Affects 1Panel-dev MaxKBSource CVE Database V5
Not known to be exploited · CVSS 3.1 Low : upgrade to 2.8.0 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.8.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 14 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade MaxKB and 1panel-dev/MaxKB to 2.8.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 1Panel-devMaxKB | Affected
| Fixed in
|
GitHub1panel-dev/MaxKBpkg:github/1panel-dev/MaxKBOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade MaxKB to version 2.8.0 or later, where this vulnerability has been fixed. Since the vendor has released a fixed version, applying this update is the recommended remediation. No other mitigation guidance is provided or necessary.
Description
CVE-2026-39419 is a vulnerability in MaxKB versions 2.7.1 and below that allows an authenticated user to bypass sandbox result validation and spoof tool execution results. The attacker exploits Python frame introspection to read a UUID from bytecode constants and writes a forged result directly to file descriptor 1, bypassing stdout redirection. By calling sys.exit(0), the attacker terminates the wrapper before legitimate output is printed, causing the service to trust the spoofed response. This issue is fixed in version 2.8.0.