Skip to main content
VulnerabilityPublished

CVE-2026-39559: Uppercase (WordPress plugin) · PHP Remote File Inclusion

Affects Uppercase (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 1.2.2 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.2.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Uppercase (WordPress plugin) to 1.2.2.

Affected software

ProductAffectedFixed in
codesupplycoUppercaseAffected
  • ≥ n/a, < 1.2.2
Fixed in
  • 1.2.2

AI-suggested

If you cannot patch yet, users should consider restricting access to vulnerable installations, applying web application firewalls with rules targeting LFI attempts, and monitoring for suspicious activity related to file inclusion attempts. Avoid exposing vulnerable versions to untrusted networks.

Description

CVE-2026-39559 is a high severity vulnerability affecting codesupplyco's Uppercase product versions prior to 1.2.2. It involves an unauthenticated Local File Inclusion (LFI) issue, classified under CWE-98, which relates to improper control of filenames in include/require statements in PHP programs. This vulnerability allows an attacker to include local files on the server without authentication. The vulnerability has a CVSS 3.1 base score of 8.1, indicating a high impact on confidentiality, integrity, and availability. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…