Skip to main content
VulnerabilityPublished

CVE-2026-39847: emmett · Path Traversal

Affects emmettSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 2.8.1 as a priority.

Data as of 28 Oct 2026, 17:11 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade emmett to 2.8.1.

Affected software

ProductAffectedFixed in
emmett-frameworkemmettAffected
  • >=2.5.0 <2.8.1
Fixed in
  • 2.8.1
PyPIemmettpkg:pypi/emmettOther threatsAffected
  • >=2.5.0 <2.8.1
Fixed in
  • 2.8.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Emmett to version 2.8.1 or later, where this path traversal vulnerability is fixed. Patch status is not explicitly confirmed beyond the version fix note, so check the vendor's official release notes for confirmation.

Description

A critical path traversal vulnerability (CWE-22) exists in the Emmett Python web framework versions 2.5.0 up to but not including 2.8.1. The vulnerability affects the RSGI static handler serving internal assets under the /__emmett__ path, allowing an attacker to use .. / sequences to access arbitrary files outside the intended assets directory. This can lead to unauthorized disclosure of sensitive files. The issue is fixed starting from version 2.8.

References

Community reviews

Loading reviews…