Skip to main content
VulnerabilityPublished

CVE-2026-39888: MervinPraison praisonaiagents · Violation of Secure Design Principles

Affects MervinPraison praisonaiagentsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 10.0 Critical : upgrade to 1.5.115 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.115
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade MervinPraison praisonaiagents to 1.5.115.

Affected software

ProductAffectedFixed in
MervinPraisonpraisonaiagentsAffected
  • <1.5.115
Fixed in
  • 1.5.115
PyPIpraisonaiagentspkg:pypi/praisonaiagentsOther threatsAffected
  • <1.5.115
Fixed in
  • 1.5.115

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade praisonaiagents to version 1.5.115 or later, where this vulnerability is fixed. There is no indication that the vulnerability is mitigated by other means or that no action is required.

Description

CVE-2026-39888 is a critical vulnerability in MervinPraison's praisonaiagents prior to version 1.5.115. The vulnerability arises from an incomplete sandboxing implementation in the execute_code() function, where the subprocess wrapper's AST-based blocklist omits key attributes that enable frame traversal. This omission allows an attacker to bypass sandbox restrictions by chaining through exception attributes to access the real Python builtins dictionary and execute arbitrary code. The vulnerability has a CVSS score of 10, indicating critical severity. A fix is available in version 1.5.115. No known exploits in the wild have been reported.

References

Community reviews

Loading reviews…