Skip to main content
VulnerabilityPublished

CVE-2026-39890: MervinPraison PraisonAI · Deserialization of Untrusted Data

Affects MervinPraison PraisonAISource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.5.115 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.115
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade PraisonAI and mervinpraison/PraisonAI to 4.5.115.

Affected software

ProductAffectedFixed in
MervinPraisonPraisonAIAffected
  • <4.5.115
Fixed in
  • 4.5.115
GitHubmervinpraison/PraisonAIpkg:github/mervinpraison/PraisonAIOther threatsAffected
  • <4.5.115
Fixed in
  • 4.5.115

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PraisonAI to version 4.5.115 or later, where this vulnerability is fixed by disabling dangerous YAML tags during parsing. Until upgraded, restrict access to the API endpoint that accepts agent definition files to trusted users only to reduce exposure.

Description

CVE-2026-39890 is a critical vulnerability in MervinPraison PraisonAI versions prior to 4.5.115. The vulnerability arises from unsafe deserialization of YAML files using the js-yaml library without disabling dangerous tags, allowing attackers to execute arbitrary JavaScript code remotely by uploading malicious agent definition files. This leads to remote code execution on the server hosting the vulnerable application. The issue is fixed in version 4.5.115. No known exploits in the wild have been reported yet.

References

Community reviews

Loading reviews…