CVE-2026-39980: opencti · Template Injection
Affects openctiSource CVE Database V5
Public exploit available (Metasploit) · CVSS 9.1 Critical : upgrade to 6.9.5 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.9.5
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade opencti and opencti-platform/opencti to 6.9.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenCTI-Platformopencti | Affected
| Fixed in
|
GitHubopencti-platform/openctipkg:github/opencti-platform/openctiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenCTI-Platform to version 6.9.5 or later, where this vulnerability is fixed. Since the vulnerability requires Manage customization privileges, restricting this capability to trusted users can reduce risk. Patch status is not explicitly stated in vendor advisory content, but the description confirms the fix in version 6.9.5. No additional mitigations are indicated.
Description
OpenCTI is an open source platform for managing cyber threat intelligence knowledge and observables. Prior to 6.9.5, the safeEjs.ts file does not properly sanitize EJS templates. Users with the Manage customization capability can run arbitrary JavaScript in the context of the OpenCTI platform process during notifier template execution. This vulnerability is fixed in 6.9.5.