Skip to main content
VulnerabilityPublished

CVE-2026-40105: xwiki-platform · Basic XSS

Affects xwiki-platformSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 6.5 Medium · fixed in 17.10.1 : update xwiki-platform when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.10.1, 17.4.8, 16.10.16
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Apr 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade xwiki-platform to 17.10.1, 17.4.8 or 16.10.16.

Affected software

ProductAffectedFixed in
xwikixwiki-platformAffected
  • >=17.5.0-rc-1 <17.10.1
Fixed in
  • 17.10.1
xwikixwiki-platformAffected
  • >=17.0.0-rc-1 <17.4.8
Fixed in
  • 17.4.8
xwikixwiki-platformAffected
  • >=10.4-rc-1 <16.10.16
Fixed in
  • 16.10.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Developers and administrators should upgrade to versions beyond the affected ranges (i.e., versions 16.10.16, 17.4.8, or 17.10.1 and later) once available. Until then, a manual patch can be applied to the templates/changesdoc.vm file in the deployed WAR to mitigate the vulnerability. Monitor the vendor's official channels for an official fix or advisory.

Description

CVE-2026-40105 is a reflected cross-site scripting (XSS) vulnerability in the XWiki Platform affecting versions from 10.4-rc-1 up to but not including 16.10.16, versions 17.0.0-rc-1 up to 17.4.8, and versions 17.5.0-rc-1 up to 17.

References

Community reviews

Loading reviews…