Skip to main content
VulnerabilityPublished Updated

CVE-2026-40155: nextjs-auth0 · Incorrect Authorization

Affects nextjs-auth0Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.4 Medium : upgrade to 4.18.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.18.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nextjs-auth0 and auth0/nextjs-auth0 to 4.18.0.

Affected software

ProductAffectedFixed in
auth0nextjs-auth0Affected
  • >=4.12.0 <4.18.0
Fixed in
  • 4.18.0
GitHubauth0/nextjs-auth0pkg:github/auth0/nextjs-auth0Other threatsAffected
  • >=4.12.0 <4.18.0
Fixed in
  • 4.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Auth0 Next.js SDK version 4.18.0 or later, where this issue has been fixed. Since this is a library vulnerability, applying the official update is the recommended remediation. No other mitigations are indicated by the vendor advisory.

Description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.

References

Community reviews

Loading reviews…