Skip to main content
VulnerabilityPublished Updated

CVE-2026-40171: jupyter notebook · Cross-site Scripting

Affects jupyter notebookSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High · fixed in 7.5.6 : patch jupyter notebook soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.5.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
jupyternotebookAffected
  • >=7.0.0 <=7.5.5
Fixed in–
jupyterlabhelp-extensionAffected
  • <=4.5.6
Fixed in–
jupyterlabjupyterlabAffected
  • <=4.5.6
Fixed in–
jupyter-notebookhelp-extensionAffected
  • >=7.0.0 <=7.5.5
Fixed in–
PyPInotebookpkg:pypi/notebookOther threatsAffected
  • >=7.0.0 <=7.5.5
Fixed in–
PyPIjupyterlabpkg:pypi/jupyterlabOther threatsAffected
  • <=4.5.6
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Jupyter Notebook 7.5.6, JupyterLab 4.5.7, and corresponding help-extension packages. Users should upgrade to these versions to remediate the vulnerability. As a workaround, disabling the affected help extensions or setting allowCommandLinker to false in the sanitizer configuration can mitigate the risk until patching is applied.

Description

### Impact A stored Cross-Site Scripting (XSS) vulnerability in Jupyter Notebook allows attackers to steal authentication tokens from users who open malicious notebook files and interact with elements that the attacker can make look indistinguishable from legitimate controls (single click interaction). The vulnerability enables complete account takeover through the Jupyter REST API, allowing the attacker to: 1. Read all files 2. Modify/create files 3. Access running kernels and execute arbitrary code 4. Create terminals for shell access ### Patches Jupyter Notebook 7.5.6 and JupyterLab 4.5.7 include patches for this vulnerability. ### Workarounds The help extension can be disabled via CLI: ``` jupyter labextension disable @jupyter-notebook/help-extension jupyter labextension disable @jupyterlab/help-extension ``` ### Hardening The patched versions include a toggle to disable the command linker functionality altogether, for example via `overrides.json`: ```json { "@jupyterlab/apputils-extension:sanitizer": { "allowCommandLinker": false } } ``` ### Resources - https://jupyterlab.readthedocs.io/en/latest/user/commands.html#commands-in-markdown-output-and-files ### Acknowledgments Reported by Daniel Teixeira - NVIDIA AI Red Team

References

Community reviews

Loading reviews…