Skip to main content
VulnerabilityPublished

CVE-2026-4430: The Document Foundation LibreOffice · Out-of-bounds Write

Affects The Document Foundation LibreOfficeSource CVE Database V5

0
Compare

Public exploit available · CVSS 5.4 Medium : upgrade to 26.2.3 or 25.8.7 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.07% chance of exploitation in 30 days – higher than 0% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.2.3, 25.8.7
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade The Document Foundation LibreOffice to 26.2.3 or 25.8.7.

Affected software

ProductAffectedFixed in
The Document FoundationLibreOfficeAffected
  • >=26.2 <26.2.3
Fixed in
  • 26.2.3
The Document FoundationLibreOfficeAffected
  • >=25.8 <25.8.7
Fixed in
  • 25.8.7
Debiandebian/libreofficepkg:deb/debian/libreofficeOther threatsAffected
  • =26.2
  • =25.8
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid opening untrusted OOXML documents that could trigger this vulnerability.

Description

An out-of-bounds write vulnerability exists in The Document Foundation's LibreOffice when processing crafted OOXML documents with mismatched encryption salt parameters. This affects LibreOffice versions 26.2 before 26.2.3 and 25.8 before 25.8.7. The vulnerability is classified under CWE-787 and has a medium severity with a CVSS 4.0 base score of 5.

References

Community reviews

Loading reviews…