Skip to main content
VulnerabilityPublished Updated

CVE-2026-40258: gramps-web-api · Path Traversal

Affects gramps-web-apiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 3.11.1 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.11.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade gramps-web-api to 3.11.1.

Affected software

ProductAffectedFixed in
gramps-projectgramps-web-apiAffected
  • >=1.6.0 <3.11.1
Fixed in
  • 3.11.1
PyPIgramps-web-apipkg:pypi/gramps-web-apiOther threatsAffected
  • <3.11.1
Fixed in
  • 3.11.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available starting with Gramps Web API version 3.11.1, which includes validation of ZIP entry paths to prevent directory traversal during media archive import. Users should upgrade to version 3.11.1 or later to remediate this vulnerability.

Description

The Gramps Web API is a Python REST API for the genealogical research software Gramps. Versions 1.6.0 through 3.11.0 have a path traversal vulnerability (Zip Slip) in the media archive import feature. An authenticated user with owner-level privileges can craft a malicious ZIP file with directory-traversal filenames to write arbitrary files outside the intended temporary extraction directory on the server's local filesystem. Startig in version 3.11.1, ZIP entry names are now validated against the resolved real path of the temporary directory before extraction. Any entry whose resolved path falls outside the temporary directory raises an error and aborts the import.

References

Community reviews

Loading reviews…