Skip to main content
VulnerabilityPublished

CVE-2026-40291: chamilo-lms · Improper Privilege Management

Affects chamilo-lmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2.0-RC.3 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0-RC.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade chamilo-lms to 2.0-RC.3.

Affected software

ProductAffectedFixed in
chamilochamilo-lmsAffected
  • <2.0-RC.3
Fixed in
  • 2.0-RC.3
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threatsAffected
  • =2.0.0-RC.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Chamilo LMS to version 2.0.0-RC.3 or later, where this vulnerability is fixed. Patch status is not explicitly stated beyond the fixed version, so verify with the vendor advisory for the latest remediation guidance. Until upgraded, restrict access to the API endpoint and review user role assignment processes to prevent unauthorized role modifications.

Description

Chamilo LMS versions prior to 2.0.0-RC.3 contain an improper privilege management vulnerability in the PUT /api/users/{id} endpoint. Authenticated users with the ROLE_STUDENT can escalate their privileges to ROLE_ADMIN by modifying the roles field on their own user record. This is due to insufficient authorization checks and the roles field being writable. Exploitation grants full administrative control over the platform, including access to all courses, user data, grades, and administrative settings. The vulnerability has been fixed in version 2.0.0-RC.

References

Community reviews

Loading reviews…