Skip to main content
VulnerabilityPublished Updated

CVE-2026-40323: succinctlabs sp1 · Insufficient Verification of Data Authenticity

Affects succinctlabs sp1Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.9 High : upgrade to 6.1.0 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.1.0
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade succinctlabs sp1 to 6.1.0.

Affected software

ProductAffectedFixed in
succinctlabssp1Affected
  • >=6.0.0 <6.1.0
Fixed in
  • 6.1.0
GitHubsuccinctlabs/sp1pkg:github/succinctlabs/sp1Other threatsAffected
  • =6.0.0
  • =6.0.1
  • =6.0.2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade succinctlabs sp1 to version 6.1.0 or later, where this vulnerability is fixed. Patch status is not explicitly confirmed beyond the version fix note; check vendor advisories for the latest remediation guidance.

Description

SP1 is a zero‑knowledge virtual machine that proves the correct execution of programs compiled for the RISC-V architecture. In versions 6.0.0 through 6.0.2, a soundness vulnerability in the SP1 V6 recursive shard verifier allows a malicious prover to construct a recursive proof from a shard proof that the native verifier would reject. Version 6.1.0 fixes the issue.

References

Community reviews

Loading reviews…