Skip to main content
VulnerabilityPublished Updated

CVE-2026-40347: Kludex python-multipart · Uncontrolled Resource Consumption

Affects Kludex python-multipartSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.0.26 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.0.26
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Kludex python-multipart to 0.0.26.

Affected software

ProductAffectedFixed in
Kludexpython-multipartAffected
  • <0.0.26
Fixed in
  • 0.0.26
PyPIpython-multipartpkg:pypi/python-multipartOther threatsAffected
  • <0.0.26
Fixed in
  • 0.0.26

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade python-multipart to version 0.0.26 or later, where the vulnerability is fixed. Patch status is not explicitly confirmed by a vendor advisory, but the description clearly states that upgrading to 0.0.26 or later addresses the issue. Until upgrade, systems remain vulnerable to denial of service via crafted multipart requests.

Description

Python-Multipart is a streaming multipart parser for Python. Versions prior to 0.0.26 have a denial of service vulnerability when parsing crafted `multipart/form-data` requests with large preamble or epilogue sections. Upgrade to version 0.0.26 or later, which skips ahead to the next boundary candidate when processing leading CR/LF data and immediately discards epilogue data after the closing boundary.

References

Community reviews

Loading reviews…