CVE-2026-40535: Synology DiskStation Manager (DSM) · Path Traversal
Affects Synology DiskStation Manager (DSM)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium · fixed in 7.3.2-86009-2 : update Synology DiskStation Manager (DSM) when convenient.
Data as of 2 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.3.2-86009-2, 7.2.2-72806-7, 7.2.1-69057-10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade synology/dsm to 7.3.2-86009-2, 7.2.2-72806-7 or 7.2.1-69057-10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SynologyDiskStation Manager (DSM) | Affected
| Fixed in– |
Synologysynology/dsmpkg:rpm/synology/dsmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions are available: DSM 7.2.1-69057-10, 7.2.2-72806-7, and 7.3.2-86009-2. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation guidance is provided or required beyond applying these official fixes.
Description
An improper limitation of a pathname to a restricted directory ('path traversal') vulnerability in Desktop API in Synology DiskStation Manager (DSM) before 7.2.1-69057-10, 7.2.2-72806-7 and 7.3.2-86009-2 allows remote attackers to write limited files and conduct limited denial-of-service attacks.