CVE-2026-40542: Apache HttpClient · Missing Critical Step in Authentication
Affects Apache HttpClientSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 5.6.1 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.6.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 22 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Apache to 5.6.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HttpClient | Affected
| Fixed in
|
Mavenorg.apache.httpcomponents/httpclientpkg:maven/org.apache.httpcomponents/httpclientOther threats | Affected
| Fixed in– |
MavenApache Software Foundation/org.apache.httpcomponents.client5:httpclient5pkg:maven/Apache Software Foundation/org.apache.httpcomponents.client5:httpclient5Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache HttpClient from version 5.6 to 5.6.1 or later, where this vulnerability is fixed. No other mitigations are specified in the vendor advisory. Patch status is confirmed by the vendor advisory recommending upgrade to 5.6.1.
Description
Missing critical step in authentication in Apache HttpClient 5.6 allows an attacker to cause the client to accept SCRAM-SHA-256 authentication without proper mutual authentication verification. Users are recommended to upgrade to version 5.6.1, which fixes this issue.
References
- lists.apache.org/thread/tfmgv86xr0z1y096vs3z0y315t1v3o97 (opens in a new tab)
- openwall.com/lists/oss-security/2026/04/22/5 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-40542 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2460518 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-40542.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60247 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60239 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60251 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60246 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60250 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60259 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60254 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60249 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60248 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60252 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60256 (opens in a new tab)