CVE-2026-40636: Dell ECS · Use of Hard-coded Credentials
Affects Dell ECSSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.3.0.0 or later as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.3.0.0 or later
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade ECS and ObjectScale to 4.3.0.0 or later.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| DellECS | Affected
| Fixed in
|
| DellObjectScale | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, restrict local access to trusted users only and monitor for any suspicious activity. Avoid deploying affected versions in untrusted environments. Follow Dell's official communications for updates on patches or mitigations.
Description
Dell ECS versions 3.8.1.0 through 3.8.1.7 and Dell ObjectScale versions prior to 4.3.0.0, contains a use of hard-coded credentials vulnerability. An unauthenticated attacker with local access could potentially exploit this vulnerability, leading to filesystem access for attacker.