Skip to main content
VulnerabilityPublished Updated

CVE-2026-40686: Exim · Out-of-bounds Read

Affects EximSource GCVE Database

0

Not known to be exploited · CVSS 3.7 Low : upgrade to 4.99.2 when convenient.

Data as of 27 Oct 2026, 00:40 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.99.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Exim to 4.99.2.

Affected software

ProductAffectedFixed in
Exim EximAffected
  • <4.99.2
Fixed in
  • 4.99.2

AI-suggested

A fix is available in Exim version 4.99.2 and later. Users should upgrade to version 4.99.2 or newer to remediate this vulnerability. No other mitigation or workaround is indicated.

Description

CVE-2026-40686 is an out-of-bounds read vulnerability in Exim versions before 4.99.2 when UTF-8 operators are enabled. The flaw occurs if malformed UTF-8 header data with large trailing characters is processed, potentially causing information disclosure through error messages during unrelated email handling. The vulnerability has a low severity rating with a CVSS score of 3.7.

References

Community reviews

Loading reviews…