Skip to main content
VulnerabilityPublished

CVE-2026-40701: F5 NGINX Plus · Use After Free

Affects F5 NGINX PlusSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.30.1 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.30.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade NGINX Open Source to 1.30.1.

Affected software

ProductAffectedFixed in
F5NGINX PlusAffected
  • =R36
  • =R32
Fixed in–
F5NGINX Open SourceAffected
  • >=1.19.0 <1.30.1
Fixed in
  • 1.30.1

AI-suggested

If you cannot patch yet, consider disabling ssl_ocsp or ssl_verify_client directives if feasible to avoid the vulnerable configuration.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_ssl_module module when the ssl_verify_client directive is set to "on" or "optional," and the ssl_ocsp directive is set to "on" or the leaf parameters are configured with a resolver. With this configuration, an unauthenticated attacker can send requests along with conditions beyond its control that may cause a heap-use-after-free error in the NGINX worker process. This vulnerability may result in limited modification of data or the NGINX worker process restarting.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

References

Community reviews

Loading reviews…