CVE-2026-40887: vendurehq vendure · SQL Injection
Affects vendurehq vendureSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 9.1 Critical · fixed in 3.6.2 : patch vendurehq vendure as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 1.7% chance of exploitation in 30 days – higher than 77% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.6.2, 3.5.7, 2.3.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: evidence found.
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade vendure and vendurehq/vendure to 3.6.2, 3.5.7 or 2.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vendurehqvendure | Affected
| Fixed in
|
| vendurehqvendure | Affected
| Fixed in
|
| vendurehqvendure | Affected
| Fixed in
|
GitHubvendurehq/vendurepkg:github/vendurehq/vendureOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Vendure has released official patches in versions 2.3.4, 3.5.7, and 3.6.2 that fix this vulnerability by parameterizing SQL queries and validating inputs. Users should upgrade to one of these patched versions to fully remediate the issue. For those unable to upgrade immediately, Vendure provides a hotfix that replaces the getLanguageCode method to validate and sanitize the languageCode input, blocking injection payloads before they reach the database. Applying this hotfix is recommended as a temporary mitigation until upgrading is possible.
Description
Vendure versions prior to 2.3.4, 3.5.7, and 3.6.2 contain an unauthenticated SQL injection vulnerability in the Shop API due to unsafe interpolation of a user-controlled query string parameter. This allows attackers to execute arbitrary SQL commands on the database. The Admin API is also vulnerable but requires authentication for exploitation. Vendure has released patched versions that fix this by parameterizing queries and providing a hotfix that validates the languageCode input to block injection attempts.