Skip to main content
VulnerabilityPublished

CVE-2026-40931: node-modules compressing · Link Following

Affects node-modules compressingSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 2.1.1 or 1.10.5 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.1.1, 1.10.5
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade compressing to 2.1.1 or 1.10.5; compressing to 1.10.5.

Affected software

ProductAffectedFixed in
node-modulescompressingAffected
  • >=2.0.0 <2.1.1
Fixed in
  • 2.1.1
node-modulescompressingAffected
  • <1.10.5
Fixed in
  • 1.10.5
npmcompressingpkg:npm/compressingOther threatsAffected
  • <1.10.5
Fixed in
  • 1.10.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in node-modules compressing versions 2.1.1 and 1.10.5. Users should upgrade to these or later versions to remediate this vulnerability. There is no indication that temporary mitigations exist or that the vendor advises no action. Patch status is confirmed by the vendor advisory stating the vulnerability is fixed in these versions.

Description

CVE-2026-40931 is a high-severity vulnerability in the node-modules compressing library affecting versions prior to 2.1.1 and 1.10.5. It involves improper link resolution before file access, where a logical path validation check fails to consider the actual filesystem state, allowing attackers to bypass security checks via directory poisoning using pre-existing symbolic links. This can lead to unauthorized file access and potential compromise of confidentiality, integrity, and availability. The vulnerability has been fixed in versions 2.1.1 and 1.

References

Community reviews

Loading reviews…