Skip to main content
VulnerabilityPublished Updated

CVE-2026-49777: Product Slider Pro for WooCommerce (WordPress plugin) · Improper Validation of Specified Quantity in Input

Affects Product Slider Pro for WooCommerce (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 10.0 Critical : upgrade to 3.5.4 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.6% chance of exploitation in 30 days – higher than 76% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.5.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Jun 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Product Slider Pro for WooCommerce (WordPress plugin) to 3.5.4.

Affected software

ProductAffectedFixed in
ShapedPlugin, LLCProduct Slider Pro for WooCommerceAffected
  • ≥ n/a, < 3.5.4
Fixed in
  • 3.5.4

AI-suggested

No vendor-provided mitigations or temporary fixes are currently documented.

Description

Improper Validation of Specified Quantity in Input vulnerability in ShapedPlugin, LLC Product Slider Pro for WooCommerce allows Malicious Software Implanted. This issue affects Product Slider Pro for WooCommerce: from n/a before 3.5.4.

References

Community reviews

Loading reviews…