CVE-2026-40933: FlowiseAI Flowise · OS Command Injection
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · 11% EPSS · CVSS 10.0 Critical : upgrade to 3.1.0 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 11.9% chance of exploitation in 30 days – higher than 96% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 21 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Flowise and flowise-components and flowiseai/Flowise to 3.1.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAIFlowise | Affected
| Fixed in
|
| FlowiseAIflowise-components | Affected
| Fixed in
|
GitHubflowiseai/Flowisepkg:github/flowiseai/FlowiseOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Flowise to version 3.1.0 or later, where this vulnerability is fixed. Since this is not a cloud service, remediation depends on user action to update the software.
Description
CVE-2026-40933 is a critical OS command injection vulnerability in FlowiseAI's Flowise product prior to version 3.1.0. It arises from unsafe serialization of stdio commands in the MCP adapter, allowing an authenticated attacker to add a malicious MCP stdio server with arbitrary commands. Despite input sanitization attempts, attackers can bypass these checks and execute arbitrary OS commands. This vulnerability is fixed in Flowise version 3.1.0.
References
- github.com/FlowiseAI/Flowise/security/advisories/GHSA-c9gw-hvqq-f33r (opens in a new tab)
- ox.security/blog/mcp-supply-chain-advisory-rce-vulnerabilities-across-the-ai-ecosystem (opens in a new tab)
- ox.security/blog/the-mother-of-all-ai-supply-chains-critical-systemic-vulnerability-at-the-core-of-the-mcp (opens in a new tab)