Skip to main content
VulnerabilityPublished

CVE-2026-40946: oxia · Improper Authentication

Affects oxiaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.2 Critical : upgrade to 0.16.2 as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.16.2
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade oxia and oxia-db/oxia to 0.16.2.

Affected software

ProductAffectedFixed in
oxia-dboxiaAffected
  • <0.16.2
Fixed in
  • 0.16.2
GitHuboxia-db/oxiapkg:github/oxia-db/oxiaOther threatsAffected
  • <0.16.2
Fixed in
  • 0.16.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade oxia to version 0.16.2 or later, where the vulnerability is fixed by properly validating the audience claim in OIDC tokens.

Description

CVE-2026-40946 is a critical improper authentication vulnerability in oxia versions prior to 0.16.2. The issue arises because the OIDC authentication provider sets SkipClientIDCheck to true, disabling audience claim validation and allowing tokens intended for other services from the same OIDC issuer to be accepted by oxia. This flaw could lead to unauthorized access. The vulnerability is fixed in version 0.16.2. No known exploits are reported in the wild.

References

Community reviews

Loading reviews…