CVE-2026-40963: Apache Airflow · Improper Authorization
Affects Apache AirflowSource CVE Database V5
Not known to be exploited · CVSS 3.1 Low : upgrade to 3.2.2 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Airflow to 3.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Airflow | Affected
| Fixed in
|
PyPIapache-airflowpkg:pypi/apache-airflowOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Apache Airflow version 3.2.2 and later. Users should upgrade to version 3.2.2 or newer to remediate this vulnerability. No other mitigation or temporary workaround is indicated.
Description
Apache Airflow version 3.0.0 has an improper authorization vulnerability in the structure_data endpoint of its UI. This flaw allows authenticated users with read access to one DAG to enumerate linked DAG IDs and dependency metadata for other DAGs they are not authorized to access. This issue affects deployments that rely on per-DAG read scoping to maintain privacy of DAG dependency topology across teams. Users are advised to upgrade to Apache Airflow 3.2.2 or later to address this issue.