Skip to main content
VulnerabilityPublished Updated

CVE-2026-40985: Spring Web Flow · Expression Language Injection

Affects Spring Web FlowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium · fixed in 4.0.0.1 : update Spring Web Flow when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.0.1, 3.0.1.1, 2.5.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Spring Web Flow to 4.0.0.1, 3.0.1.1 or 2.5.2.

Affected software

ProductAffectedFixed in
SpringSpring Web FlowAffected
  • >=4.0.0 <4.0.0.1
Fixed in
  • 4.0.0.1
SpringSpring Web FlowAffected
  • >=3.0.0 <3.0.1.1
Fixed in
  • 3.0.1.1
SpringSpring Web FlowAffected
  • >=2.5.0 <2.5.2
Fixed in
  • 2.5.2

AI-suggested

If you cannot patch yet, avoid configuring the WebFlowELExpressionParser with untrusted input or disable expression evaluation where possible.

Description

Applications that configure the WebFlowELExpressionParser are vulnerable to the use of malicious Unified EL expressions. Affected versions: Spring Web Flow 4.0.0; 3.0.0 through 3.0.1; 2.5.0 through 2.5.1.

References

Community reviews

Loading reviews…