CVE-2026-41705: Spring AI · Expression Language Injection
Affects Spring AISource CVE Database V5
Not known to be exploited · CVSS 8.6 High : upgrade to 1.1.6 or 1.0.7 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.6, 1.0.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 9 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Spring AI to 1.1.6 or 1.0.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring AI | Affected
| Fixed in
|
| SpringSpring AI | Affected
| Fixed in
|
AI-suggested
Upgrade affected Spring AI versions to 1.0.7 or greater for the 1.0.x branch and 1.1.6 or greater for the 1.1.x branch as these versions contain fixes for this vulnerability. Patch status is not explicitly confirmed in the vendor advisory, so users should consult official Spring AI advisories for the latest remediation guidance. No alternative mitigations or workarounds are indicated.
Description
Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs. Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.