Skip to main content
VulnerabilityPublished Updated

CVE-2026-6665: PgBouncer · Stack-based Buffer Overflow

Affects PgBouncerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 1.25.2 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.25.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade PgBouncer to 1.25.2.

Affected software

ProductAffectedFixed in
PgBouncerAffected
  • <1.25.2
Fixed in
  • 1.25.2

AI-suggested

Since the vulnerability affects versions before 1.25.2, upgrading to version 1.25.2 or later is likely the intended remediation once officially released. Until then, monitor vendor communications for an official fix. No other specific mitigations are indicated in the available data.

Description

The SCRAM code in PgBouncer before 1.25.2 did not check the return value of strlcat() correctly when building the contents of the SCRAM client-final-message. A malicious backend that sends a SCRAM server-final-message with a long nonce can trigger a stack overflow.

References

Community reviews

Loading reviews…