CVE-2026-40996: Spring Web Services · Weak Cryptography
Affects Spring Web ServicesSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium · fixed in 5.0.1.1 : update Spring Web Services when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.0.1.1, 4.1.3.1, 4.0.19 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Spring Web Services to 5.0.1.1, 4.1.3.1, 4.0.19 or 3.1.9.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SpringSpring Web Services | Affected
| Fixed in
|
| SpringSpring Web Services | Affected
| Fixed in
|
| SpringSpring Web Services | Affected
| Fixed in
|
| SpringSpring Web Services | Affected
| Fixed in
|
AI-suggested
Operators should explicitly reconfigure the allowRSA15KeyTransportAlgorithm flag to false to avoid accepting RSA PKCS#1 v1.5 encrypted key material. Monitoring vendor communications for an official fix or update is recommended.
Description
Wss4jSecurityInterceptor defaulted allowRSA15KeyTransportAlgorithm to true, overriding Apache WSS4J's safer default for validation RequestData. Inbound WS-Security decryption could therefore accept RSA PKCS#1 v1.5 (rsa-1_5) encrypted key material unless operators explicitly reconfigured the flag. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.