Skip to main content
VulnerabilityPublished Updated

CVE-2026-41014: Apache Airflow · Missing Authorization

Affects Apache AirflowSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 3.2.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 30% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 24 Oct 2026.

What to do

Upgrade Apache Airflow to 3.2.2.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache AirflowAffected
  • >=3.2.0 <3.2.2
Fixed in
  • 3.2.2
PyPIapache-airflowpkg:pypi/apache-airflowOther threatsAffected
  • =3.2.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Airflow to version 3.2.2 or later, where this authorization issue has been addressed. No other mitigation or temporary workaround is indicated. Patch status is not explicitly confirmed in the vendor advisory data, but the recommendation to upgrade to 3.2.2 or later implies an official fix is available in those versions.

Description

CVE-2026-41014 is a medium severity vulnerability in Apache Airflow 3.2.0 where the partitioned_dag_runs endpoints enforce only asset-level access control but not per-DAG authorization. This allows authenticated users with global Asset:read permission to enumerate partition run state, schedule configuration, and asset wiring for DAGs they are not authorized to access. The issue affects deployments relying on per-DAG read scoping combined with broader asset access. Users are advised to upgrade to Apache Airflow 3.2.2 or later.

References

Community reviews

Loading reviews…