Skip to main content
VulnerabilityPublished

CVE-2026-41046: presire qSnapper · Relative Path Traversal

Affects presire qSnapperSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 1.3.3 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade qSnapper and qsnapper to 1.3.3.

Affected software

ProductAffectedFixed in
presireqSnapperAffected
  • <1.3.3
Fixed in
  • 1.3.3
GitHubqsnapperpkg:github/qsnapperOther threatsAffected
  • <1.3.3
Fixed in
  • 1.3.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict local access to trusted users and validate or sanitize inputs related to the "configName" parameter to mitigate exploitation risk.

Description

A path traversal attack when using a "configName" parameter in qSnapper before version 1.3.3 allowed a local attacker to use malicious config files for snapper and so cause a denial of service or potentially escalate privileges to root.

References

Community reviews

Loading reviews…